HELP

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

ParkerS
Posts: 1
Joined: Wed Jul 11, 2018 1:03 pm

HELP

Postby ParkerS » Wed Jul 11, 2018 1:11 pm

I have a 2008 Volvo s40 and at the beginning of the summer I went to turn my ac on and it was pumping hot air so I bought a recharge kit, ac worked great for a while then all of a sudden at random times it started blowing hot air, it’s switches between blowing ice cold and hot air, I have a gauge and it says it’s running at 45psi my car recommends 17psi so I lowered the psi to 17 and nothing but hot air so I filled it back up to 45psi and again half the time it will blow ice cold and the other half it will blow hot air. If anyone has any idea what is causing this I would really appreciate it :)
JohnHere
Posts: 85
Joined: Sun May 13, 2018 10:20 am
Location: South Carolina Upstate

Re: HELP

Postby JohnHere » Sat Jul 14, 2018 5:59 pm

I suggest getting the vehicle to a reputable A/C shop to recover whatever refrigerant is in it, evacuate, and recharge it precisely by weight. Then they'll evaluate both the low-side and high-side pressures and make repair recommendations from there.

Those recharge kits with a single gauge are notorious for being next to useless, and they sometimes contain sealer, too, which can completely ruin an A/C system and a professional shop's expensive equipment. Here's hoping you didn't introduce any sealer into your A/C system.

Return to “Automotive Air Conditioning Forum”