2009 GMC Arcadia compressor starts and stops

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

Seascot1
Posts: 1
Joined: Thu Aug 01, 2019 8:14 pm

2009 GMC Arcadia compressor starts and stops

Postby Seascot1 » Thu Aug 01, 2019 8:22 pm

Hello all. Recently had fitted new condenser new fan and pressure switch. Compressor cycles on and off to often. Runs for a few 2nds then stops. Then starts 10 secs later and stops. I have had gauges on it. At ambient temp without running system pressure is about 120 psi. And 40 psi on low side. After car has been sitting for a while and starts up cold i start the compressor and see press changes high side goes up.to near 200psi and low towards 25. But I dont see the condensor fan running.

After this the compressor just cycles on and off around 120 psi every few secs.

If I cycle the ac button in car on and off the compressor does try to start each time but only for a few secs again.


Should the condensor fan run as soon as ac button is pushed ? Or is it run on pressure?. Does condensor fan run at 2 speeds. I have seen it running at its appears slow.to.me.

Does anyone now what set point the HP switch has.i.am.living in miami so ambient is 90F plus.

Thanks
User avatar
Cusser
Posts: 456
Joined: Sun Apr 24, 2016 6:29 am

Re: 2009 GMC Arcadia compressor starts and stops

Postby Cusser » Thu Aug 01, 2019 8:36 pm

Seascot1 wrote:I start the compressor and see press changes high side goes up.to near 200psi and low towards 25.


Sounds to me like a little low on R134a.

As to both fans being on when AC is switched on, I would "think" yes, but I don't know. I think both electric fans come on with the AC on our 2005 Yukon.
GM Tech
Posts: 162
Joined: Fri Apr 22, 2016 7:22 am

Re: 2009 GMC Arcadia compressor starts and stops

Postby GM Tech » Tue Aug 06, 2019 7:53 am

Your Arcadia is well known for evaporator leaks--to fix is a dash pull- I've seen a few and done a few- about a 10 hour job. Look for green dye in the drain hose- under gas pedal under the truck.
Cautrell05
Posts: 1
Joined: Thu Jun 20, 2019 9:32 am

Re: 2009 GMC Arcadia compressor starts and stops

Postby Cautrell05 » Tue Aug 06, 2019 8:36 pm

First off it sounds like it's low on 134. The fans run based off system pressure. At 200psi it probably hasn't seen enough pressure to turn them on.

Second, as a current GM tech id say check the condenser and lines for any signs of dye. If you don't find one then it's about 97% certain that the rear evaporator is the cause of the leak. Our parts department has sold over 60 in the last year and I think I've only seen one or two front evaporators replaced on the last ten years. According to gm, the failure is because of brush material from the rear blower motor causing corrosion on the core. Not sure if that's it or just a poor design.

Nick

Return to “Automotive Air Conditioning Forum”