AC working, but vent air still not cold

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, JohnHere, Dougflas, Tim

Post Reply
kbear
Posts: 2
Read the full article
Joined: Thu Apr 15, 2021 2:11 pm

AC working, but vent air still not cold

Post by kbear »

Hello Auto AC forum,

It seems quite certain that the ac system is working in my 2013 Impala.

I am getting a water puddle on my driveway when the ac is left on, but NOT when it is left off.
The light on the knob (under the snowflake image) will go on and remain on.
I can see the compressor clutch is turning.
Fluid pressure is about 30 psi on low side when compressor is engaged.

However, the air coming out of the vent inside the car remains same as ambient temperature (about 90 deg F).

When I put the temperature selection to a higher temp, the air from the vent DOES get much hotter, so I know the temperature blend door is working.

Any input or ideas would be greatly appreciated.
User avatar
Cusser
Posts: 630
Joined: Sun Apr 24, 2016 6:29 am

Re: AC working, but vent air still not cold

Post by Cusser »

kbear wrote: Thu Apr 15, 2021 2:17 pm Fluid pressure is about 30 psi on low side when compressor is engaged.

Any input or ideas would be greatly appreciated.
Need high side pressure when running at about 1800 rpm. If you don't have such service gauges, then silly to try to diagnose yourself.

kbear wrote: Thu Apr 15, 2021 2:17 pm When I put the temperature selection to a higher temp, the air from the vent DOES get much hotter, so I know the temperature blend door is working.

Any input or ideas would be greatly appreciated.
Unless your flap/door is not fully closing.....

NEVER ADD ANY SEALANT OR REFRIGERANT CONTAINING SEALANT !!! EVER !!!
Dougflas
Posts: 374
Joined: Mon Apr 18, 2016 6:10 pm

Re: AC working, but vent air still not cold

Post by Dougflas »

clamp off the heater hoses. You may have a reheat problem.
kbear
Posts: 2
Joined: Thu Apr 15, 2021 2:11 pm

Re: AC working, but vent air still not cold

Post by kbear »

Thanks, I'll look into clamping off heater hoses. Not sure how to do that right off.
User avatar
JohnHere
Posts: 446
Joined: Sun May 13, 2018 10:20 am
Location: South Carolina Upstate - USA

Re: AC working, but vent air still not cold

Post by JohnHere »

I've done it a few times using inexpensive gluing clamps from the local home center. Large Vise Grips will also work, but I'd pad the jaws with something so they don't damage the heater hoses.
tbirdtbird
Posts: 288
Joined: Sat May 02, 2020 1:48 pm

Re: AC working, but vent air still not cold

Post by tbirdtbird »

we use small blocks of wood
Post Reply