Very Little Cooling

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

Dgreen
Posts: 75
Joined: Thu Jun 16, 2016 4:08 am

Very Little Cooling

Postby Dgreen » Wed Apr 10, 2019 5:37 pm

2010 Buick LaCrosse that isn’t cooling well. Vacuumed and recharged to the amount listed under the hood. At 1500 rpms. High side was 200 and low was 55. At idle the low side would sometime be as high as 70. Has something gone bad in the compressor? Lowest vent temp was 65.
Dougflas
Posts: 256
Joined: Mon Apr 18, 2016 6:10 pm

Re: Very Little Cooling

Postby Dougflas » Wed Apr 10, 2019 8:53 pm

Could be blend door actuator, heater reheat problem, compressor control valve. Now that you have the correct refrigeration level, time to troubleshoot.
GM Tech
Posts: 162
Joined: Fri Apr 22, 2016 7:22 am

Re: Very Little Cooling

Postby GM Tech » Thu Apr 11, 2019 2:00 am

Low side at 70?? Whoa Nelly- there-in lies your problem. Nothing cools at 70 low side- should be near 25-35. I suspect your variable compressor control valve is bad-- You can change it yourself- while it is on the car normally- just has to have system discharged.....
Dgreen
Posts: 75
Joined: Thu Jun 16, 2016 4:08 am

Re: Very Little Cooling

Postby Dgreen » Thu Apr 11, 2019 2:15 am

Thanks!

I have experienced a control valve problem on my nephew’s Ford 500 a couple years ago. I didn’t know GM also used them.
Dgreen
Posts: 75
Joined: Thu Jun 16, 2016 4:08 am

Re: Very Little Cooling

Postby Dgreen » Thu Apr 11, 2019 12:10 pm

Control valve for this thing is hard to find.

Any suggestions? Tried Ackits already.
User avatar
Tim
Site Admin
Posts: 306
Joined: Tue Apr 12, 2016 2:19 pm
Location: Scottsdale, Arizona
Contact:

Re: Very Little Cooling

Postby Tim » Thu Apr 11, 2019 2:33 pm

------------------------------
Please support ACKITS.com for your Auto A/C Parts and Tool needs.
P:602-233-0090
Dgreen
Posts: 75
Joined: Thu Jun 16, 2016 4:08 am

Re: Very Little Cooling

Postby Dgreen » Tue Apr 16, 2019 1:05 pm

That looks like it.

Return to “Automotive Air Conditioning Forum”