Toyota pickup AC questions

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

PromiseRing
Posts: 20
Joined: Thu May 24, 2018 2:28 pm

Toyota pickup AC questions

Postby PromiseRing » Sat Jul 21, 2018 9:16 pm

Hey guys. First post here, I am a newbie with automotive ac but am fascinated by it. I am 'self taught' (by forums and YouTube) and doing my best to learn as much as I can. I have successfully fixed 5 or so cars of mine and close friends. I find it very satisfying!

Here comes a long post, bear with me..

So, my neighbor has a 93 Toyota pickup that was originally an r12 system. Has been InOp for about 8 years or so. I offered to help her get it going. I installed some r12>r134a adapters, vacuumed the system for a while, and charged with 1 12oz can of r134. I know this isn’t the ideal way to do things but it worked very well. Ac was almost immediately ice cold. I had one concern, high side pressures were very high, around 350psi IIRC. Low side was around 35-40 I think which seemed normal to me. I had told her i was concerned about the high side pressures and that maybe there was a restriction in the system. When I was reading the gauges I had a big powerful fan pointed directly at the condenser so there should have been sufficient airflow. I know a lack of airflow willl cause high pressures so that’s why I used the fan. Oh, truck uses a clutch fan instead of efans so that's another reason I had an auxiliary fan up front.

Anyway, fast forward 1 week. Her ac has been terrific. Then today she told me she heard a loud boom/pop noise and the ac no longer worked. Compressor had green dye all over it that I don’t think was there prior. I hooked up the gauges and there was still some pressure in the system. I decided to vacuum it down again and add 1 can of r134a again just like I did before. Compressor came on like it should but the air from the vents was hot. I noticed the the high side pressures only got up to around 100psi now, and the low side pressures were 70 until the compressor stayed on, then they dropped into vacuum! Like 20-25 in Hg. I thought this was weird and indicated a restriction in the system. So I bought a TXV and went to install it but it was the wrong part, great. Took the original unit and blew compressed air through both sides until I was able to blow my breath through the entrance with ease. This makes me believe it is not clogged.

Put the truck back together, vacuumed it, and added 2 cans of r134a this time. Same scenario. High side pressures were around 100, low side were in vacuum.

So, I have no idea what to do. I’d love to fix her ac for her so she can drive around with her dog in the summer. I appreciate any advice you guys can give me, and sorry again for the lengthy post.
JohnHere
Posts: 117
Joined: Sun May 13, 2018 10:20 am
Location: South Carolina Upstate

Re: Toyota pickup AC questions

Postby JohnHere » Sun Jul 22, 2018 8:22 pm

R-12 to R-134a conversions like this don't usually cool quite as well as the original R-12 refrigerant did. But to make it work satisfactorily, this conversion requires some specific procedures that must be completed before evacuating and recharging a system with the new refrigerant. Your intentions are good, but in this instance, you missed a few key steps that probably caused additional problems that will now have to be fixed.

Oil is a major consideration with these conversions. R-12 systems used mineral oil while R-134a systems use PAG (Polyalkylene Glycol) oil. Because mineral oil isn't compatible with, and won't mix with, R-134a, the mineral oil must be completely removed from the system first. This is done by removing the compressor, draining whatever mineral oil will come out of the ports, and then flushing the compressor with PAG oil at least twice to remove any remaining mineral oil. Use only PAG 46 oil for this, not solvent.

Next step is to flush, with approved A/C solvent and air pressure, the rest of the system, and by that I mean the evaporator and lines. You'll need to get all traces of mineral oil and debris out of them as well. However, if the lines have mufflers in them (can-like devices), the lines will have to be replaced because mufflers can't be flushed.

Instead of trying to flush the original tube-and-fin condenser, I would just replace it with a new one (or a parallel-flow type if you can find one that fits), as well as the receiver/dryer (R/D) and thermostatic expansion valve (TXV). Be sure the R/D you get is compatible with R-134a.

Now, since you worked on it, your neighbor experienced a malfunction that caused a mixture of R-134a, mineral oil, and UV dye to blow out somewhere. A combination of the mineral oil still in the system and R-134a refrigerant on top of that most likely created an acidic sludge that plugged things up and starved the compressor for lubricant. This caused the high-side pressure spike and the subsequent blow-out. Since the compressor is now able to generate only about 100 PSI on the high side, even with two cans of refrigerant in the system, I suspect that the compressor is shot. So it, too, will have to be replaced.

The low side pulling into a vacuum probably was caused by a faulty or clogged TXV and/or the evaporator being plugged up (or partially so) by the mineral oil / R-134a sludge.

My source documentation for that truck specifies an original charge of 29 ounces of R-12 and 7 ounces of mineral oil. You will need only about 80 percent of the original spec using R-134a and the full 7 ounces of (in this instance) PAG 46. So you should charge about 23.2 ounces of R-134a. As for the oil, before buttoning everything up, I would put 4-1/2 ounces in the compressor, 1 ounce each in the condenser and evaporator, and 1/2 ounce in the R/D. One ounce extra, spread out among the components, probably wouldn't hurt anything, either.
PromiseRing
Posts: 20
Joined: Thu May 24, 2018 2:28 pm

Re: Toyota pickup AC questions

Postby PromiseRing » Mon Jul 30, 2018 5:25 pm

Thank you so much for the reply. I have read into a bit and she has decided to have me install nearly all new AC parts. Would you mind taking a look at this list if parts? I have a new compressor, condenser, evaporator, pag46 oil, orings, TXV, and receiver drier. Am I missing anything? Thanks again!

I’m seeing 2 possible TXVs listed. One is normal flow and one is reverse flow. I have no idea which one she has, is there a way to tell?
User avatar
bohica2xo
Posts: 562
Joined: Wed May 11, 2016 4:12 pm
Location: Las Vegas, NV

Re: Toyota pickup AC questions

Postby bohica2xo » Mon Jul 30, 2018 6:17 pm

The dessicant bag in that dryer is swollen up like a sausage. Stop before it bursts an fills the system with muck.

Blowing the HPRV let out some oil, so yes you need to flush & start again from square 1.

I see you plan a total system replacement. That will work too. Be sure to flush out the hoses, and if there are any mufflers or "cans" in the hose, those are almost impossible to flush...
JohnHere
Posts: 117
Joined: Sun May 13, 2018 10:20 am
Location: South Carolina Upstate

Re: Toyota pickup AC questions

Postby JohnHere » Tue Jul 31, 2018 1:06 pm

You're really getting into it now :D

In your list of parts, you mention a "new" compressor. I would ensure that it's brand new and not a rebuilt unit, which are known to give problems. There's nothing worse than installing a rebuilt compressor that soon leaks or otherwise fails and then having to do the job all over again. The OEM for this vehicle is Denso, by the way.

Recall that this truck originally had R-12 in it. So the new compressor might come pre-filled with mineral oil. As discussed earlier, you will have to get all the mineral oil out. Drain and carefully measure whatever oil comes out of the new compressor, flush it a couple of times with PAG-46, then refill it with an equal amount of fresh PAG-46 before installation. The rest of the PAG-46 should be distributed throughout the system as already discussed.

I believe that this truck has a combination HP/LP cut-off switch from the factory. If so, you won't need to install a separate switch.

Everything else on your list looks good. Just a reminder that the desiccant in the R/D must be compatible with R-134a.

The difference in the TXV's (regular flow versus reverse flow) refers to where the high-pressure and low-pressure lines connect. IIRC, in the regular-flow version, the high-pressure (liquid) line connects to the TXV just below the diaphragm while the low-pressure (suction) line connects on the bottom opposite the diaphragm. A reverse-flow TXV connects the other way around. You'll have to examine what's in it now and get the one that matches the original.

Once it's all back together, evacuate the system to 29 InHg or lower for at least 1/2-hour, ensure that it holds vacuum, charge it to about 80-percent of the R-12 spec, and do a performance check.

My 1994 Camry Wagon V6, which has a factory R-134a system, doesn't have any mufflers or "cans" in the lines. If this truck doesn't, either, you should be able to re-use the lines after flushing them well as bohica2xo suggests, assuming they're still in good shape and leak free.
PromiseRing
Posts: 20
Joined: Thu May 24, 2018 2:28 pm

Re: Toyota pickup AC questions

Postby PromiseRing » Fri Aug 03, 2018 8:53 am

Thank you both for your replies again. Parts are ordered and will be here today, but i will not be able to begin work until next week.

@bohika2xo, yes I plan on replacing just about every part I can. The only things I will need to flush are just the high and low pressure lines, correct? Everything else will be new. Is there any affordable AC flush for the lines? I have an air compressor but surely I’ll need some type of solvent to remove the sludge. Lastly, if there is any type of non-flushable muffler, and I can’t find a replacement, can I just bypass it with a straight tube? I know a couple pipefitters so that wouldn’t be an issue.

@JohnHere, the compressor I bought was in fact a denso unit but I do not believe it specified if it was new or remanned. I’ll check again but I hope it’s new. If it comes filled with mineral oil I will drain it, measure, flush it twice, and replace with pag46. I did not see whether or not the R/D was r12 or r134a specific, if it is not compatible with r134, I will try to find one that is. However, I was also wondering if I could just fill with some ES12A or duracool instead. Lastly, I will have to further inspect the the TXV to see which one it uses. I’m hoping the one I ordered was the correct unit.

Thanks again for your guys replies, I will keep posted.
PromiseRing
Posts: 20
Joined: Thu May 24, 2018 2:28 pm

Re: Toyota pickup AC questions

Postby PromiseRing » Sun Aug 05, 2018 7:11 am

After reading some more about flushing the lines, it seems that mineral spirits and compress air should work only because r12 uses mineral oil to begin with. I’d imagine there’s only a few small ac lines that need to be flushed. Everything else will be new.
JohnHere
Posts: 117
Joined: Sun May 13, 2018 10:20 am
Location: South Carolina Upstate

Re: Toyota pickup AC questions

Postby JohnHere » Sun Aug 05, 2018 10:46 am

Yes, you'll need to flush only the lines and not the new components. If mufflers are present, you can remove and replace them with lengths of tubing. I doubt whether you'll notice much if any difference in the system's sound level.

You mentioned in your last post using mineral spirits as a flushing solvent. I would hesitate to do so because it evaporates slowly, increasing the difficulty of getting it all out of the lines. I've heard of people using brake cleaner as well. But neither of these solvents is specifically designed for flushing mobile A/C systems and might not be compatible with the refrigerant and oil if any residue is left behind.

To play it safe, I would use a solvent intended only for automotive A/C systems, like those offered by the site sponsor. At the very least, you'll also need a canister designed to inject the solvent through the lines under pressure. I prefer the one in which you connect your air compressor to one side and have the pressurized solvent come out the other, like this one: http://www.ackits.com/flush-equipment-a ... wgun-25615

As for refrigerants, I don't recommend using any of the "alternatives," which are hydrocarbon (propane) based. Over and above the obvious fire hazard risk, you'd be taking a chance with their performance characteristics as well, and you could end up once again with a malfunctioning or non-functioning system. You won't go wrong staying with pure R-134a containing no sealers or enhancers and PAG-46 oil.
User avatar
Cusser
Posts: 394
Joined: Sun Apr 24, 2016 6:29 am

Re: Toyota pickup AC questions

Postby Cusser » Sun Aug 05, 2018 3:34 pm

PromiseRing wrote:After reading some more about flushing the lines, it seems that mineral spirits and compress air should work only because r12 uses mineral oil to begin with.


1. Mineral spirits and R-12 "mineral" oil are not related.

2. Some mineral spirits sold these days is not all hydrocarbons, contains emulsion with water, so be aware of that !!!

3. Use a real AC flush solvent.
PromiseRing
Posts: 20
Joined: Thu May 24, 2018 2:28 pm

Re: Toyota pickup AC questions

Postby PromiseRing » Mon Aug 06, 2018 4:58 pm

Thanks guys! Guess I’ll hit up the auto parts store and hope I can find something local for the flush.

Checking the parts over now, I’m thinking my TXV is not the correct size, just like the first one I bought.

The compressor says nothing about any oil being added alread. Can I take off the top to see if oil is in there? It also came with its own orings so I’m thinking maybe it’s empty and they expect you to open it.

My R/D says r12 on it, so I’ll see if the autoparts store has one that’s r134 compatible. Probably not worth my time returning this one to rock auto. Edit: just checked around. I’m having trouble finding one that says it’s compatible with r134a. Any chance I can get away with this one or am I asking for failure in less than a year? :|

Return to “Automotive Air Conditioning Forum”