Stumper for the experts

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, JohnHere, Tim

tbirdtbird
Posts: 900
Read the full article
Joined: Sat May 02, 2020 1:48 pm
Location: Texas

Stumper for the experts

Post by tbirdtbird »

We have a 1987 Porsche 928 S4 in the shop due to front AC not working. Rear AC works fine. Was converted to 134 before current owner bought the car.
At 1500 RPM , 35 psig low, 250 psig hi. Ambient 85F
Front evap runs off block valve. No idea what the expansion device is for the rear.
Front block valve gets cold, as do the 2 pipes from it going thru the firewall to the evap. Not ice cold, but cold. Can only see/feel about one inch of these 2 pipes.
Vent temp is 110F. This is not re-heating, hot water pipe going thru firewall is lukewarm. System seems to be controlled by combination of electronics and vacuum. Almost nothing has any type of access at all. Dash would have to be removed to get anywhere near evap.

Have traced out a bunch of pipes and wires and damper doors and nothing is broken or malfunctioning.
Ideas? Thanks Dave
When considering your next auto A/C purchase, please consider the site that supports you: www.ACKits.com
DetroitAC
Posts: 243
Joined: Mon Oct 17, 2016 10:33 am
Location: SE Michigan

Re: Stumper for the experts

Post by DetroitAC »

Yes, and sorry to deliver the bad news.

Evaps can have a manufacturing defect that allows an internal leak from the inlet side to the outlet side. Most people think the inlet of an evaporator is mostly liquid, a lot of textbooks call it a low pressure liquid, it's just not true, there is a tiny amount of liquid in a huge flow of vapor. If there is even a tiny hole all the liquid tries to go through it, the vapor will mostly scream through the evap passages, it gets heated up to ambient temp almost immediately and then flows through the remainder of the plates or tubes at the same temperature. The highly superheated vapor mixes with the liquid in the evap outlet tank/header to become a normally superheated flow, this is still actively controlled by the TXV, the TXV senses this re-mixed together flow.

Bad evap, so sorry, especially in an old Porsche, not a fun job.
tbirdtbird
Posts: 900
Joined: Sat May 02, 2020 1:48 pm
Location: Texas

Re: Stumper for the experts

Post by tbirdtbird »

OK, thanks, Detroit, will report back
When considering your next auto A/C purchase, please consider the site that supports you: www.ACKits.com
tbirdtbird
Posts: 900
Joined: Sat May 02, 2020 1:48 pm
Location: Texas

Re: Stumper for the experts

Post by tbirdtbird »

Calling Detroit AC or anyone
Detroit, if our problem is as you suggest, how cool/cold should we expect the in and out pipes of the block TXV to be? They are pretty much the same temp and cool but not cold. Again, rear AC blows cold.
We removed the block valve and bench tested it before we committed to extensive dash removal/etc.
The valve functions perfectly
When considering your next auto A/C purchase, please consider the site that supports you: www.ACKits.com
DetroitAC
Posts: 243
Joined: Mon Oct 17, 2016 10:33 am
Location: SE Michigan

Re: Stumper for the experts

Post by DetroitAC »

Way too many unknowns for me to be able to guess.
DetroitAC
Posts: 243
Joined: Mon Oct 17, 2016 10:33 am
Location: SE Michigan

Re: Stumper for the experts

Post by DetroitAC »

Now that I think about it, could also be pin leakage in your H-block TXV, does exactly the same thing, test it for internal leakage 1st. A very tiny leak is ok, but if it has a pin o-ring that is disintegrated you could get a short circuit there if the pin/bore fit is loose enough
tbirdtbird
Posts: 900
Joined: Sat May 02, 2020 1:48 pm
Location: Texas

Re: Stumper for the experts

Post by tbirdtbird »

OK, thanks.
I'll follow up. It will be a few days, we just had a cold front drop in and the weather won't be over 70 for several days
When considering your next auto A/C purchase, please consider the site that supports you: www.ACKits.com
tbirdtbird
Posts: 900
Joined: Sat May 02, 2020 1:48 pm
Location: Texas

Re: Stumper for the experts

Post by tbirdtbird »

Calling Detroit AC or anyone
OK, more info on this Porsche front and rear AC. Please recall the rear AC has always blown cold.
You had mentioned that 134 could be shunting by the needle in the front H-block.
(we are still trying to avoid pulling the dash)
So we changed out the block valve. Easy to do. We accidentally overcharged by 1 lb. We decided to study it with the overcharge (35 lo, 350 hi at 1500 RPM, 75 ambient, yes low ambient I know. Once we get on the right track we will dial it in at 85 or 90. Had a cold front go thru). At this hi side pressure, we had 65F out the front vents, and the rear always blows about 40F. The block valve was cold to the touch (not ice cold but cold).
As we recovered the 1 pound of 134, we noticed the block valve warmed up and the front vents went to 90F.

Turns out both front and rear evap operate on a TXV!!
I was always taught that cannot work, although I am not sure why. (WHY?)
Our theory right now is that the superheat on the rear TXV is set way too low and is starving (shunting) the front TXV of 134. Or the rear TXV has failed in the wide open position, doing the same thing.

OK, just learned the rear TXV is also a block valve. Was hoping it was a standard TXV so I could dial up the superheat. Can block valves be adjusted?

Appreciate your thoughts
Dave
When considering your next auto A/C purchase, please consider the site that supports you: www.ACKits.com
DetroitAC
Posts: 243
Joined: Mon Oct 17, 2016 10:33 am
Location: SE Michigan

Re: Stumper for the experts

Post by DetroitAC »

Front and rear TXV is OK, it's just a bit more difficult because of feedback problems. Both TXVs have control over not only their own superheat but also the suction pressure in the shared suction pipe, and they are both also influenced by suction pressure. Two TXVs tend to find conditions in which they will cause each other to oscillate and then the entire system will oscillate. In practice the TXVs need measures taken to slow their response time down, friction clips, absorption charges in the heads, bleeds, insulated or restricted internal access to the dome, etc.

If the rear TXV was flooding it would pull charge from the receiver first, then the condenser and the liquid line, both the front and rear liquid lines would be running bubbly pretty much equally.

How in the world did the front vent temperature go to 90 if ambient was 75F? I thought you were sure it's not the heater core adding heat?
tbirdtbird
Posts: 900
Joined: Sat May 02, 2020 1:48 pm
Location: Texas

Re: Stumper for the experts

Post by tbirdtbird »

Detroit, sorry, misprint, with normal gauge pressures front climbed to 80. We still do not think there is much if any reheating. The foam edging may be shot? Just try to get inside this front evap/suitcase.

When the system was overcharged, the front evap worked much better, so somehow the overpressure ? forced more 134 through the valve? That is where we came up with the idea that the rear valve was shunting 134 away from the front.

I have noticed a brass disc or plug on the bottom of the valve, but it only has one small hole, and it is perfectly round, not made for an allen key. And only one hole! If it had been 2 holes, like I see on some of the valves at the Egelhof site, I would have already fiddled with it.

Here is a pic of the end of Egelhof valve. I am tempted to drill a second small hole in the brass plug. It does seem the plug is threaded into the body.
With 2 holes I know I can turn it. I have an old valve and I can play with it.
Ideas?

Just for giggles we are tempted to raise the superheat in the rear, and lower it in the front....nothing to lose.
egelhof.jpg
egelhof.jpg (146.72 KiB) Viewed 426 times
When considering your next auto A/C purchase, please consider the site that supports you: www.ACKits.com
Post Reply