Page 3 of 3

Re: Evaporator Switch-Themoswitch Question

Posted: Thu Sep 17, 2020 1:25 pm
by digeratimvp
Ok back on topic, these were the readings at noon today.

12:00PM
85F outside, I was in a covered garage that was not in the sun felt like 78-80F

Pressures at 1500rpm:
35 Low
225 High

With box fan in front
30 Low
200 High

So my thinking is the (new) Expansion Valve (bulb type) is ok.
There is sweating on the low side line going all the way to the compressor and its 60-61F at the outlet of the evap at the firewall, using a infrared thermometer.

Using same thermometer, its about 145F at the high side of compressor, then at the bottom of condenser about 125F and 114 at the top of it.
Then as it goes into the drier, its sometimes 95F to 105F on each side of it, (in and out) and sometimes its 114F.

The high side going into the firewall into the evap is about 95F.

I am trying to determine if there is still an exapansion valve issue, or if its simply the thermoswitch, or have I missed something else?

I am kind of leaning towards taking it all apart AGAIN, and putting in the expansion valve that was working on it to begin with.

Re: Evaporator Switch-Themoswitch Question

Posted: Fri Sep 18, 2020 6:06 am
by Cusser
digeratimvp wrote:When its bypassed, it gets the vents down to 35F, of course because its freezing down there.



I personally would not monkey again with the expansion valve or the refrigerant charge, as great cooling occurs if the switch is bypassed or is "closed". I'd focus on the thermo switch which needs to close more often, or do some sort of bypass.