Damaged R12 shraeder valve when installing R134a adapter

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

r-mm
Posts: 28
Joined: Sun Jul 01, 2018 1:25 pm

Damaged R12 shraeder valve when installing R134a adapter

Postby r-mm » Thu Apr 30, 2020 6:01 pm

I have installed a few sets of R134a adapters over the years without issue. I went out of my way to get a quality set for my '91 Porsche and asked the mfgr to confirm the existing shraerder on the R12 is supposed to remain in place. They said yes. As precaution I replaced the R12 fitting shraeders before beginning. I then charger the system.

From the outset the install of the adapters seemed odd. I didn't recall having pressure release as the adapter is being screwed on before, maybe I forgot or the other systems I worked on were empty. When I had the adapter installed I could not get a pressure reading with the R134a quick connect manifold. I removed the adapter and found the R12 shraeder bent and damaged.

Has anyone dealt with this before?
james89dx
Posts: 13
Joined: Fri Jul 08, 2016 7:25 am

Re: Damaged R12 shraeder valve when installing R134a adapter

Postby james89dx » Fri May 01, 2020 1:15 pm

What is damaged on the schrader side exactly? Is it the outside threads or just the inner core? If the core, you can replace just the core for fairly cheap and easily.

This might be your car's last stand fighting you to the death saying "stay R12, stay R12" lol.
r-mm
Posts: 28
Joined: Sun Jul 01, 2018 1:25 pm

Re: Damaged R12 shraeder valve when installing R134a adapter

Postby r-mm » Fri May 01, 2020 1:20 pm

Haha true.

The manufacturer of the adapter confirmed they accidentally sent the wrong install instructions. The old Shraeder must come out. I can't entirely see into the port but i think the stem cracked the threaded portion somewhat.
Waco1mex
Posts: 1
Joined: Sat May 02, 2020 6:41 pm

Re: Damaged R12 shraeder valve when installing R134a adapter

Postby Waco1mex » Fri May 22, 2020 10:29 pm

I have a 1985 c10 do I need to remove the Schrader valve before I put new retrofit
r134a ports

Return to “Automotive Air Conditioning Forum”