R12 system on 79 Trans Am

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

warrenseale
Posts: 11
Joined: Wed Mar 18, 2020 8:28 am

Re: R12 system on 79 Trans Am

Postby warrenseale » Sat Mar 21, 2020 5:06 am

The inlet and outlet lines of the evaporator are cool, not cold as they normally should be. The hot/cold damper door is functioning properly.
User avatar
Tim
Site Admin
Posts: 347
Joined: Tue Apr 12, 2016 2:19 pm
Location: Scottsdale, Arizona
Contact:

Re: R12 system on 79 Trans Am

Postby Tim » Sat Mar 21, 2020 7:09 am

Unless I'm missing something. Full Refrigerant, cool inlet and outlet lines, hardly any variation from static pressure. Compressor spinning.

Seems to be a bad compressor.
------------------------------
Please support ACKITS.com for your Auto A/C Parts and Tool needs.
P:602-233-0090
Al9
Posts: 14
Joined: Tue Mar 10, 2020 3:26 am

Re: R12 system on 79 Trans Am

Postby Al9 » Sat Mar 21, 2020 8:07 am

Agree, definitely sounds like a compressor featuring either seriously worn pistons/cylinder walls or broken reed valves.
warrenseale
Posts: 11
Joined: Wed Mar 18, 2020 8:28 am

Re: R12 system on 79 Trans Am

Postby warrenseale » Sun Mar 22, 2020 9:38 am

Well I opened up the system and pulled the orifice tube and found a couple pieces of rubber that looks like o ring material but which is not from the pipes/hoses. More concerning is that the screen was loaded with metal particles. Prior to the rebuild when I pulled the original 40 year old orifice tube, there was no debris plus I flushed and blew out the system prior to installing the compressor. Now I have to deal with the rebuilder :x
User avatar
JohnHere
Posts: 179
Joined: Sun May 13, 2018 10:20 am
Location: South Carolina Upstate - USA

Re: R12 system on 79 Trans Am

Postby JohnHere » Mon Mar 23, 2020 11:04 am

Offhand, I don't know what the specs are for your car. But if the rebuilt compressor was empty of oil when you received it, did you add the correct amount and type of oil?
warrenseale
Posts: 11
Joined: Wed Mar 18, 2020 8:28 am

Re: R12 system on 79 Trans Am

Postby warrenseale » Tue Mar 24, 2020 10:59 am

The rebuilder fills it with 11 oz of ester oil. This is the full oil capacity of the system. Anyway, they are having me ship it back to them.
Al9
Posts: 14
Joined: Tue Mar 10, 2020 3:26 am

Re: R12 system on 79 Trans Am

Postby Al9 » Wed Mar 25, 2020 6:13 am

Which viscosity might be an interesting question. The A6 is pretty sturdy but too thin of a oil and friction becomes a problem.
warrenseale
Posts: 11
Joined: Wed Mar 18, 2020 8:28 am

Re: R12 system on 79 Trans Am

Postby warrenseale » Fri Mar 27, 2020 12:09 pm

Well the rebuilder received and inspected the compressor and found an extra o ring inside it. They removed it and said that otherwise the internals look OK. They said the extra o ring would have caused the symptoms I experienced. We'll see! At least they turned it around in one day and paid for shipping to and from. The final testing shows it is working normally. I asked if they tested it the first time when the extra o ring was in place. They said that either they missed that step :o or it checked out OK at the time.
User avatar
JohnHere
Posts: 179
Joined: Sun May 13, 2018 10:20 am
Location: South Carolina Upstate - USA

Re: R12 system on 79 Trans Am

Postby JohnHere » Sat Mar 28, 2020 8:56 am

I wonder where the metal particles came from, though. Usually, that means something inside the compressor is disintegrating, as mentioned earlier.
warrenseale
Posts: 11
Joined: Wed Mar 18, 2020 8:28 am

Re: R12 system on 79 Trans Am

Postby warrenseale » Sun Mar 29, 2020 9:24 am

JohnHere wrote:I wonder where the metal particles came from, though. Usually, that means something inside the compressor is disintegrating, as mentioned earlier.


Most likely from the compressor prior to the rebuild. Some particles could have been sitting in the bottom evaporator tank even after the flush.

Return to “Automotive Air Conditioning Forum”