Search found 35 matches

by Mr Bill
Sat Sep 22, 2018 8:12 am
Forum: Automotive Air Conditioning Forum
Topic: 2004 GMC Sierra 1500
Replies: 1
Views: 2913

Re: 2004 GMC Sierra 1500

cvetteman wrote:I do not see a connector on the high pressure AC Line, so where do I connect my manifold gauges?
Should be to the left of the accumulator, small line with port sticking up.
by Mr Bill
Fri Sep 14, 2018 7:42 am
Forum: Automotive Air Conditioning Forum
Topic: Peanut not sitting flush
Replies: 6
Views: 1715

Re: Peanut not sitting flush

This is the same fitting I found on a YouTube video, the o-ring looks about the same.
by Mr Bill
Fri Sep 14, 2018 6:23 am
Forum: Automotive Air Conditioning Forum
Topic: Peanut not sitting flush
Replies: 6
Views: 1715

Re: Peanut not sitting flush

It could be the bolt in the accumulator is bent back some, I think if it were bent more towards the hole/opening it would set more flush. You could try a washer under the nut,don't know if that might help. that's a very poor design, at least what would have probably been be better is, if they would ...
by Mr Bill
Tue Jun 05, 2018 6:21 am
Forum: Automotive Air Conditioning Forum
Topic: New compressor. Not cooling well.
Replies: 21
Views: 1632

Re: New compressor. Not cooling well.

ice-n-tropics wrote:Suction side filters are available but do not filter the fines.
hotrodac
They don't make an inline high side filter?
by Mr Bill
Mon Jun 04, 2018 9:40 am
Forum: Automotive Air Conditioning Forum
Topic: New compressor. Not cooling well.
Replies: 21
Views: 1632

Re: New compressor. Not cooling well.

Dgreen wrote:I think it’s fixed. Much better numbers now.
It was 81 degrees outside and low humidity. 35%
1500 rpms
Low side 37
High side 245
Vent temp 48
Awesome! glad you got it going, enjoy the a/c now. :D
by Mr Bill
Sun Jun 03, 2018 4:11 pm
Forum: Automotive Air Conditioning Forum
Topic: New compressor. Not cooling well.
Replies: 21
Views: 1632

Re: New compressor. Not cooling well.

They did warranty it. I was honest with them. I just can't figure out why the original orifice tube looked clean. When my compressor failed I never knew the cause, because I got the car from someone else. The orifice was also clean, but I still flushed the system, and very little of anything come o...
by Mr Bill
Sun Jun 03, 2018 7:48 am
Forum: Automotive Air Conditioning Forum
Topic: New compressor. Not cooling well.
Replies: 21
Views: 1632

Re: New compressor. Not cooling well.

Before starting this job, I looked at the orfice tube. It looked good. I just pulled the new tube out and it is packed with crud. My theory is original compressor crapped out, but was low enough on refrigerant that it didn't spread the gunk around. After installing the new compressor and a full cha...
by Mr Bill
Sun Jun 03, 2018 6:31 am
Forum: Automotive Air Conditioning Forum
Topic: New compressor. Not cooling well.
Replies: 21
Views: 1632

Re: New compressor. Not cooling well.

At idle Low side 62 High side 195 Vent temp 75 1500 rpm Low side 56 High side 325 Vent temp was going down, but not like it should. Fan will hold a rag on the grill at idle. Sprayed water on the condenser and vent temp was still in the high 70s at idle. Is the new compressor the culprit? Looking fr...
by Mr Bill
Fri Jun 01, 2018 7:47 am
Forum: Automotive Air Conditioning Forum
Topic: COLD AIR BUT SURGES WHEN DRIVING
Replies: 6
Views: 622

Re: COLD AIR BUT SURGES WHEN DRIVING

Seems backward that the pump cycles on when pressure gets high. Not weird at all, it's probably cycling off on LPCO at higher RPM's, so when it cycles off, the pressures equalize and rise, closing the LPCO and bringing the compressor back on. I would find me a decent set of gauges, and you might tr...
by Mr Bill
Fri Apr 20, 2018 2:33 pm
Forum: Automotive Air Conditioning Forum
Topic: Santech Compressor Parts.
Replies: 3
Views: 6280

Re: Santech Compressor Parts.

Hey Tim, I had to search my PC for my user name and password, I really shouldn't stay away so long, I actually like this place, even if I'm no automotive ac guru. :D

Go to advanced search