Replaced compressor, failed again 9 days later. Advice sought

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

Dougflas
Posts: 200
Joined: Mon Apr 18, 2016 6:10 pm

Re: Replaced compressor, failed again 9 days later. Advice sought

Postby Dougflas » Thu May 17, 2018 4:44 am

Do not forget to use the black light and glasses on the evaporator drain tube.
hcanning
Posts: 7
Joined: Mon May 14, 2018 11:33 pm

Re: Replaced compressor, failed again 9 days later. Advice sought

Postby hcanning » Thu May 17, 2018 11:38 am

Just realised the pressure readings are written on the piece of paper I have!

Ambient temp: 21c
Vent temp: 5c
Low pressure S/R: 2.0
High pressure S/R: 7.5

Presumably these readings are in Bar!
JohnHere
Posts: 19
Joined: Sun May 13, 2018 10:20 am

Re: Replaced compressor, failed again 9 days later. Advice sought

Postby JohnHere » Sat May 19, 2018 9:14 am

It took me a little while to make the conversions to US measures and interpret them, but here's what I think is going on.

Given an ambient temp of 21C (70F) and a vent temp of 5C (41F), the LP gauge reading of 2.0BAR (29PSI) seems just about right. However, the HP gauge reading of 7.5BAR (109PSI) is way too low. It should be around 12.1BAR (175PSI) at that ambient temp and at the nearly maximum refrigerant charge of 440g (14.9 oz) that you mentioned earlier.

Therefore, the data above suggest that the rebuilt compressor you had installed was defective from the beginning since it was not building pressure the way it should. It could also be that whatever was causing the pressure issue, plus a compressor leak someplace (shaft seal??), also caused it to lose refrigerant and oil and to disintegrate internally.

At this point, if I was working on this, I would install a brand-new (not rebuilt) compressor; a new condenser and R/D assembly; guesstimate the oil level, adding or removing oil as needed; recharge the system into a well-held vacuum; then run it for a couple of weeks and see how it does. I'll bet that your problem will be solved.
hcanning
Posts: 7
Joined: Mon May 14, 2018 11:33 pm

Re: Replaced compressor, failed again 9 days later. Advice sought

Postby hcanning » Sat May 19, 2018 10:19 am

Thanks for your analysis! This is probably the avenue I’ll take.

Those pressures were measured at idle speed though, not at 1500rpm. Can’t imagine it’ll make much difference though.
JohnHere
Posts: 19
Joined: Sun May 13, 2018 10:20 am

Re: Replaced compressor, failed again 9 days later. Advice sought

Postby JohnHere » Sat May 19, 2018 11:23 am

Right...at 1,500 RPM, the LP reading will be a little lower and the HP a little higher. But I think the HP would still be much too low.
Let us know how you make out.

Return to “Automotive Air Conditioning Forum”