Page 1 of 1

69 Camaro Back Again from 2007...

Posted: Thu Sep 15, 2016 10:29 am
by jweb47
I had a post in 2007 http://www.autoacforum.com/messageview. ... adid=17957 and I'm repairing the system after an apparent compressor failure (stuck internal reed valve suspected) so I'm going to flush the system.
Since this is basically a hybrid system (everything OEM except compressor and condenser) and yes I did use the POA valve set for R134. For some reason I can't find my notes on the quantity of oil I used. Everything will be flushed except for the compressor and drier which of course are new. I plan to use 6 oz. (PAG 46) in the compressor, 3 oz. for the drier/lines but am uncertain about the rest. Can anyone help me on this one? Thanks

Re: 69 Camaro Back Again from 2007...

Posted: Thu Sep 15, 2016 10:43 am
by HECAT
I do not have the oil quantity requirement for your system, but I would GUESS it needs about 6-8 ounces of oil. So you may be good with your 9 oz. plan.

Re: 69 Camaro Back Again from 2007...

Posted: Thu Sep 15, 2016 11:13 am
by jweb47
I'm about to go out to take it all apart and flush so maybe someone will have another recommendation later on before I seal everything. Thanks for your input though. (I seem to recall your user name from years ago)

Re: 69 Camaro Back Again from 2007...

Posted: Thu Sep 15, 2016 11:24 am
by HECAT
Yup, been around so long, I thought the "grumpy old man" avatar fit.

Re: 69 Camaro Back Again from 2007...

Posted: Thu Nov 02, 2017 4:48 am
by jasmyndube
So you may be good with your 9 oz. plan. Phen375

Re: 69 Camaro Back Again from 2007...

Posted: Tue Nov 07, 2017 7:55 am
by gusepina
HECAT wrote:I do not have the oil quantity requirement for your subito.it
system, but I would GUESS it needs about 6-8 ounces of oil. So you may be good with your 9 oz. plan.


Nobody in forum..

Re: 69 Camaro Back Again from 2007...

Posted: Tue Nov 07, 2017 8:06 am
by HECAT
If you have questions ask away, or maybe start a new topic.