Evaporator is freezing up

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

skfast
Posts: 1
Joined: Tue Sep 26, 2017 6:43 am

Evaporator is freezing up

Postby skfast » Tue Sep 26, 2017 7:23 am

I’m working on a 1995 Toyota T100 AC. The issue I’m having is the evaporator is freezing up. Here are the things that have been done:
The first thing was I took it to an AC shop, there they removed the evaporator coil cleaned it replaced the expansion valve, replaced the dryer and recharged the system. The evaporator still froze up when I got it back. My observation at this point was that the compressor was not cycling. I can keep it from freezing by manually turning the AC on and off, not a good option. I read online that when the temperature gets below 32 the compressor should cycle off to keep the evaporator from freezing up. I took it back the shop. The tech told me that sometime Toyota ACs are finicky if you don’t use OEM parts. He said he would replace the expansion valve with a Toyota OEM part. I ask him about the High / Low pressure switch on the coil? He said he tested it with an ohm meter and it tested good. When I got the truck back the evaporator still froze up. I called the Shop back the Tech said he didn’t know of anything else to try. At this point I decided to start replacing parts, choosing between the easiest and cheapest first. I replaced the blower fan and the blower motor resistor (didn’t help). After some research I found that there is a temperature sensor (thermistor) on the coil. It tells the system when the coil is freezing and to cycle the compressor. I replaced the sensor and still have the same issue. Next I plan to replace the amplifier assembly. It’s the next logical thing that controls the compressor operation. Has anyone had a similar issue with their AC?

Return to “Automotive Air Conditioning Forum”