going crazy!!! please help me before i loose it ! lol

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

caliguy559
Posts: 4
Joined: Wed Jun 14, 2017 3:42 pm

going crazy!!! please help me before i loose it ! lol

Postby caliguy559 » Wed Jun 14, 2017 3:50 pm

Hi Guys! i hope yall can help me im loosing it..

i changed the compressor and drier on my wifes 2011 nissan ALtima 2.5
and i did a vacuum and filled it with what I think is well enough maybe too much freon , but yet it only shows 35 on low and 175 on high ( 80 degree day )
i put about 2 1/2 cans (12 oz) ??? unless i have a leak somewhere? but it held a 20 min vacuum at -30psi? I did accidentally open the high pressure twice while I was adding freon and it blew some freon all over the place for a split second ..also every time I connect the gauges it seems like it holds a little amount under high pressure until I Release the pressure Of whatever is left in the gauges after I dissconet , itll spray the remainings to the ground about 1/4 ounce I would say maybe more .. idk if that's normal ? And I did that many times throughout this ordeal , I would say 10 times..
Also it blows decent air not as cold as it should be i say about 80% cold
biggest issue is Compressor never cycles off? im worried about that really .
I read readings again late in the day ( 90 degrees)
My static readings were 80 and 80
And my dynamic were 42 and 185
And I went to clean the condensor while AC running and readings went down to 30 and 145 is that normal ?
User avatar
bohica2xo
Posts: 169
Joined: Wed May 11, 2016 4:12 pm
Location: Las Vegas, NV

Re: going crazy!!! please help me before i loose it ! lol

Postby bohica2xo » Thu Jun 15, 2017 8:17 am

Sounds like you have some gauge coupler issues.

Some of the really cheap stuff has no shutoff at the coupler. This is usually when you get refrigerant spraying out when disconnecting,

You have to have the right amount of refrigerant in those tiny systems for proper operation. A small error is all it takes to effect performance.

The pressure drop with a wet condenser is normal.
caliguy559
Posts: 4
Joined: Wed Jun 14, 2017 3:42 pm

Re: going crazy!!! please help me before i loose it ! lol

Postby caliguy559 » Thu Jun 15, 2017 12:36 pm

So those pressure are not definitive measurements of the freon in the system? Also today I turn on AC and it took minutes to start somewhat cooling ? It's not that hot today like 90 ..
User avatar
bohica2xo
Posts: 169
Joined: Wed May 11, 2016 4:12 pm
Location: Las Vegas, NV

Re: going crazy!!! please help me before i loose it ! lol

Postby bohica2xo » Thu Jun 15, 2017 3:51 pm

Pressures are only an indication of how well the system is (or is not) operating.

Charging is done by weight, because the refrigerant can exist as both a liquid & a gas within the same system depending on temperature & pressure. There is no simple way to measure the volume of the refrigerant with a pressure gauge.

The quantity of oil in the system also affects operation. When you changed the compressor did you drain the oil from the old one & measure it?

Why was the compressor changed?
caliguy559
Posts: 4
Joined: Wed Jun 14, 2017 3:42 pm

Re: going crazy!!! please help me before i loose it ! lol

Postby caliguy559 » Thu Jun 15, 2017 4:57 pm

i replaced the compressor because it started leaking oil from behind the shaft. it was still blowing cold air at the time..most of the oil leaked out. so i changed it and added about 4.5 ounces because i figured theres some oil left in the the system? so i filled it up with 3 cans so far but had some hiccups so some was lost.. so really i dont know how much is in there, but im pretty sure its more than 19 ounces.. i remember a couple of times i accidently opened the low and high ports on the gauges and pressures dropped to zero on the low side. but it was only for split second.. you think i should just recover the freon and put back the correct amount and check ?
User avatar
bohica2xo
Posts: 169
Joined: Wed May 11, 2016 4:12 pm
Location: Las Vegas, NV

Re: going crazy!!! please help me before i loose it ! lol

Postby bohica2xo » Thu Jun 15, 2017 9:28 pm

You can add some refrigerant, and see where things go - sometimes you get lucky.

Run the engine speed up to 1500 rpm or higher. Cabin fan on highest speed, doors open Monitor the high side pressure as you add to the low side.

When the pressures on the high side get to 2.8 times the ambient temperature, Stop adding refrigerant.

Record the pressures & the vent temp - post them here.
caliguy559
Posts: 4
Joined: Wed Jun 14, 2017 3:42 pm

Re: going crazy!!! please help me before i loose it ! lol

Postby caliguy559 » Sat Jun 17, 2017 2:10 am

Ok guys I took it to a local shop to check how much freon is actually in there , I was expecting A LOT..
TO MY AMAZEMENT, he recovered Exactly 1.2 lbs !!! That's exactly how much it calls for! Lol he did take out about 1-2ouncea of oil as well and it seems to be cooling a lil better now.. its actually pretty good now.. What a weird crazy journey this been.. hopefully it's good now! If not I'll be back lol

THANKS GUYS!

Return to “Automotive Air Conditioning Forum”