Ford Ranger 2.5L 2011 / Mazda BT50 - Compressor keeps jerking / Stops and run

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

dyord
Posts: 1
Joined: Mon May 01, 2017 10:49 pm

Ford Ranger 2.5L 2011 / Mazda BT50 - Compressor keeps jerking / Stops and run

Postby dyord » Mon May 01, 2017 11:36 pm

Hi! I live here in the Philippines where weather condition ranges from 32-37 deg. C in summer (March to May), and 24-30 deg. C in rainy season and towards December.

History:

I've had this truck since 2014 (bought it 2nd hand). The AC was very cold and I had no complains. Then early last year, it started blowing hot air.

The compressor just stopped spinning all the way. The engine is jerking when in idle. Looks like the compressor wanted to spin but won't get through. Brought it to different mechanics but the problem never went away.

1st mechanic checked the guage and the readings were 30 psi on low pressure, then whooping 350 psi on high pressure. He bled the pressure 'till it gets to 200 psi. He told me that the condenser is overheating, we have to fix the clutch fan. Now fixed, just after few weeks.. it started blowing "not so cold" air again.

Brought it to another mechanic and he cleaned the entire system. Replaced the drier filter and de-clogged the whole tubing. Then re-filled with fresh 134a refrigirant. Readings were 40 psi and 200 psi on low and high pressure.

But just after few months, problems arise again. This time, it ran out of refrigirant. So I had it refilled again with fresh 134a with 30 psi and 150 psi readings. Just after few days after that, the compressor started jerking again. Brought it to a nearest mechanic shop just to get readings, and it read 30 psi and 400 psi on low and high pressure.

What's going on?!?

Return to “Automotive Air Conditioning Forum”