Won't take charge

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

Tobeornottobe
Posts: 3
Joined: Wed Feb 22, 2017 7:25 am

Won't take charge

Postby Tobeornottobe » Wed Feb 22, 2017 7:33 am

Hi new here and need some help. I replaced my compressor, expansion valve and dryer.
2005 Jeep Grand Cherokee 4.7v8 flushed system blew out with air.

Put in proper amount and weight of oil , vacuumed and tested for leaks! I tried charging system and it will only take about half a 12oz can .
Compressor clutch is working I get 80 on low side and 50 on high side!
What the heck I'm frustrated !!! Any advice? Thanks
User avatar
Cusser
Posts: 113
Joined: Sun Apr 24, 2016 6:29 am

Re: Won't take charge

Postby Cusser » Wed Feb 22, 2017 8:24 am

Are you sure that your connections are actually pushing down enough to open the schraeder valves? Is there a difference if you push down on them?
Tobeornottobe
Posts: 3
Joined: Wed Feb 22, 2017 7:25 am

Re: Won't take charge

Postby Tobeornottobe » Wed Feb 22, 2017 9:19 am

I pretty sure they are I'll pull hose off low side and see if it's sucking! Thanks
Yes they are both opening !
Tobeornottobe
Posts: 3
Joined: Wed Feb 22, 2017 7:25 am

Re: Won't take charge

Postby Tobeornottobe » Thu Feb 23, 2017 7:56 am

Well I had to take it to shop, guy said he had to reset computer (high and low pressure settings)
He charged it up runs perfect!!
Thanks
User avatar
Cusser
Posts: 113
Joined: Sun Apr 24, 2016 6:29 am

Re: Won't take charge

Postby Cusser » Thu Feb 23, 2017 9:07 am

Good. You still saved a lot by doing all the R&R yourself.

Return to “Automotive Air Conditioning Forum”