Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

Sanden SD7h15 leaking after car sat at bodyshop ~3 months

Spikepaga on Mon July 06, 2015 7:17 AM User is offlineView users profile

Year: 1995
Make: Jaguar
Model: XJS
Engine Size: 4.0
Refrigerant Type: R134
Ambient Temp: 95
Country of Origin: United States

Hello everyone!

I dropped of my car at the body shop about 3 months ago and my AC was working fine, when I picked it up a couple of days ago, there was warm air blowing. The system had enough that the compressor would still engage, but no cold air. It took a couple of cans of R 134 to get cool air again. I put dye in there, and there seems to be a tiny amount of glow at a high pressure hose juncture (probably an o ring) and a small line of glow along the compressor pulley. As well as right by the expansion valve. The car was not leaking before.

So is all this from the car sitting for 3 months? Anything to do other than replace the compressor, the expression valve, leaking o ring (and drier of course) ??

I knew systems leak from lack of use and dried out seals, but this seems extreme after 3 months! All the parts that are leaking are less than 3 years old

Any help greatly appreciated

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.