Automotive Air Conditioning Information Forum (Archives)

Provided by

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

Fiesta 2011 AC issue

Fiesta2011 on Sun July 05, 2015 8:30 PM User is offline

Year: 2011
Make: ford
Model: fiesta
Refrigerant Type: R134
Ambient Temp: 100
Pressure Low: 50
Pressure High: 325

Hello All,

I have a strange issue with my Fiesta AC. It works fine in outside temps up to about 85F from there on it works for a few minutes and than blows hot humid air for a few minutes. Sometimes it will go longer without issues.

I connected the pressure gauges today after running the car for about an hours so its warm. Outside temp was 100F and I got 50psi Low and 325psi High. the AC air inside dropped to about 60F at the ac outlet. I also hosed the condenser and it looks clean.

It all looks fine so I am not sure what is going on and what to do next.



Edited: Sun July 05, 2015 at 8:32 PM by Fiesta2011

GM Tech on Sun July 05, 2015 9:36 PM User is offline

Air gap too wide comes to mind

The number one A/C diagnostic tool there is- is to know how much refrigerant is in the system- this can only be done by recovering and weighing the refrigerant!!
Just a thought.... 65% of A/C failures in my 3200 car diagnostic database (GM vehicles) are due to loss of refrigerant due to a leak......

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.