Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

AC trouble

stiff1970 on Sun May 10, 2015 2:01 PM User is offline

Year: 2006
Make: jeep
Model: commander

hey everyone

First off, I do not know much about air conditioners other than what I can read online.

A few days ago my jeep stopped blowing cold air. I took a video of the engine when the ac is off and on. I noticed there is quite a loud noise coming from the ?compressor? and the front fan is not moving when the ac is on.

I have attached a video. please let me know if you can help, thanks

jeep- youtube

Edited: Sun May 10, 2015 at 2:04 PM by stiff1970

stiff1970 on Sun May 10, 2015 2:03 PM User is offline

[L=]https://youtu.be/U0apUvqw3nw[/L]

mk378 on Sun May 10, 2015 2:27 PM User is offline

Sounds like something inside the compressor is broken. Maybe just the splines holding the front plate to the shaft have stripped. Either way, you're looking at at least a new compressor. If the compressor came apart inside, the system will be contaminated with metal debris that will cause a repeat failure without a lot of flushing or replacing of parts.

Fans on late model vehicles are usually pressure controlled, so when there's no pressure produced by compressor-- fan doesn't start.

Edited: Sun May 10, 2015 at 2:29 PM by mk378

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.