Automotive Air Conditioning Information Forum (Archives)

Provided by

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

Aircon temp rises on recirculation

Jambo on Mon April 21, 2014 1:59 PM User is offline

Year: 2007
Make: Kia
Model: Cee'd LS (Diesel)
Engine Size: 1.6
Ambient Temp: 12c
Country of Origin: United Kingdom


Last year i had the aircon regassed no problems when it was done last May.

Yesterday it wasn't that hot about 12c but it still felt pretty warm yesterday enough to have the aircon on for a little while,When i got in the car i put the aircon on max the air felt cold out of the centre vents but not really cold,the centre vent temperature didn't reach 5c untill i hit the open road at 50mph.

If i put it in recirculated mode then the temperature went up but only by two so instead of 5c it was 7c,Both fans come on when i start the aircon.

The aircon pipe does get cold but not really cold and has no condensation on the pipe.

Thanks for reading

mk378 on Mon April 21, 2014 5:23 PM User is offline

A leak-tight system wouldn't need to be regassed every year. Have your mechanic recover the refrigerant and weigh how much comes out. If it is considerably less than a full charge, some effort should be taken to find the leak.

Edited: Mon April 21, 2014 at 5:25 PM by mk378

Jambo on Mon April 21, 2014 6:21 PM User is offline

Will do that but im not sure there is a leak and not sure it needs regassing,Been reading into it could be the fans are not running faster enough.

mk378 on Mon April 21, 2014 6:54 PM User is offline

With such a low ambient it should be getting fully cold at the vents even when performing marginally. If the suction pipe were getting very cold you could consider that the air is being reheated in the cab. But the first thing to check here is the charge level, at least measure the high side pressure. Seeing the high side pressure will differentiate if it is a low charge or poor condenser performance.

Jambo on Tue April 22, 2014 1:50 PM User is offline

Booked in now being looked at when the service is due,But now im thinking it could be a airflow problem because if i i close off all vents all but one then that vent blows icy cold while at idle or driving around at low speeds,I think having all the vents open is causing the problem which ive never had before.

mk378 on Tue April 22, 2014 5:39 PM User is offline

That is also typical of a low charge-- if you don't try to move as much heat you don't need as much refrigerant.

Jambo on Wed April 23, 2014 4:23 AM User is offline

Didn't think of it like that,that makes sense.

It seems to be behaving today saying that though no sun just the nasty rain but still warmish outside 10c To see if the aircon was taking the heat away from inside the car i turned the blower on full heat for 10minutes to get the car all toasty then turned it to max aircon cold,All face vents open took the reading from centre vent which went down to 6c with recirculate on,Turned off recirculate and turned the blower speed down a bit and was then getting 4c.

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.