Automotive Air Conditioning Information Forum (Archives)

Provided by

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

Need help with 96 Chevy tahoe

Simon30 on Tue August 20, 2013 7:31 PM User is offlineView users profile

Year: 1996
Make: Chevrolet
Model: Tahoe
Engine Size: 5.7 gas
Refrigerant Type: 134A
Ambient Temp: 89
Pressure Low: 65
Pressure High: 250
Country of Origin: United States

I have a 96 Tahoe that hasn't had working AC for 8 years. I decided to start reading and do it myself. I am a boat mechanic but never had any AC experience so this sounded fun to me. I bought a set of mastercool gauges and an electric 2.5 Cfm vacuum pump. I got a new GPD compressor, new GPD condenser, new GPD clutch fan and accumulator. I even bought new hoses, seal kit and orifice tube. I flushed out the evaporator with alcohol, blew it out for at least 20 minutes. I vacuumed the system for 60 minutes, it held vacuum like a charm. I put the right amount of oil in the system and three 12 ounce cans of R134a. The best I've gotten out of the vent is 59 degrees. When I mist the condenser the high pressure drops from 250 to 200 and low side doesn't really change, neither does vent temp. I even pinched off the heater hose, moved the orifice tube from the condenser to the evaporator. Anyone have any ideas?

Cussboy on Tue August 20, 2013 7:57 PM User is offline

Not trying to insult you, but this is new to you, so I need to ask:

after you pulled the vacuum, and it held, did you add the refrigerant into the vacuum, or did you have a manifold gauge disconencted or something and air got into the system? Because your low pressure reading is too high, like maybe air got into the system?

GM Tech on Wed August 21, 2013 7:10 AM User is offline

You've got alcohol in your system- never flush with anything you can't get out...

The number one A/C diagnostic tool there is- is to know how much refrigerant is in the system- this can only be done by recovering and weighing the refrigerant!!
Just a thought.... 65% of A/C failures in my 3200 car diagnostic database (GM vehicles) are due to loss of refrigerant due to a leak......

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.