Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

compressor noise when not engaged

smokekiki on Sun July 28, 2013 12:30 PM User is offline

Year: 1999
Make: Chevy
Model: Astro
Engine Size: 4.3
Refrigerant Type: 134
Ambient Temp: 84 humid
Pressure Low: 50
Pressure High: 180
Country of Origin: United States

I had a compressor replaced. The bearing in the clutch was very noisey. The shop was having a hard time getting the clutch off. It had 110000 thousand miles on it. It was a $100 extra to put a new Delphi compressor on. The system was flushed, and a new accumilator and o tube installed. It was vacuumed.,and recharged.
At idle it is 50 low and 180 high. At 1500 it is 44 low and 225 high,with 43 vent temp.That is about what the vent temp has always been. Everything is quite when engaged. When a/c is turned off,there is a noise coming from the pulley. Once in a while the clutch will move an 1/8th turn. Is the clutch to tight?

WyrTwister on Sun July 28, 2013 3:00 PM User is offlineView users profile

I am confused . New compressor ? If so , was a new clutch factory installed or was the old pulley ( with new bearing ) & clutch installed on the new compressor ?

Do you have a noisy idler pulley . Noisy / worn / cracker / defective belt ?

God bless
Wyr

smokekiki on Sun July 28, 2013 4:02 PM User is offline

New compressor with factory clutch. Definitely from the a/c pulley. Put a new belt on. It sounds more like the pulley is rubbing the clutch plate,steel on steel, not like a bad bearing.

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.