Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

97 Sable Erratic Vent Temps

Minx on Mon May 31, 2010 7:04 PM User is offlineView users profile

Year: 1997
Make: Mercury
Model: Sable
Engine Size: V6
Refrigerant Type: 134a
Ambient Temp: 95
Pressure Low: 40
Pressure High: 250

This car cooled great last season -- vent temps in the upper 30s after run-in -- but now it's barely dropping below 60 (center vent, max setting) at idle and up to 1500 RPM.

With the gauges on, I run it up to 1500 and get the high side up to 300 but the low side barely moves -- stays about 40. Also the compressor doesn't cycle.

On the highway I can get the vent temp down to 48 and there is rise-and-fall, indicating it's cycling.

I checked the condenser for obstructions and bent fins. The compressor and dryer were changed out 3-4 years ago and correctly vacuumed and recharged.

What should I try next?

TRB on Tue June 01, 2010 2:37 PM User is offlineView users profile

Might check that the hot water shutoff valve is working or that you are not getting hot air mixed with the cool.

-------------------------

When considering your next auto A/C purchase, please consider the site that supports you: ACkits.com
Contact: ACKits.com

Minx on Thu June 03, 2010 4:04 PM User is offlineView users profile

Quote
Originally posted by: TRB
Might check that the hot water shutoff valve is working or that you are not getting hot air mixed with the cool.

I hope this was a valid test? I watched the vent temp after starting from a cold start -- before the engine thermostat opened. No difference in AC performance.

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.