Automotive Air Conditioning Information Forum (Archives)

Provided by

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

Compressor not engaging

jiffyp20 on Thu August 06, 2009 2:22 AM User is offline

Year: 1992
Make: Buick
Model: Regal
Engine Size: 3.8L
Refrigerant Type: R-134a
Ambient Temp: 75
Pressure Low: 45psi
Pressure High: 200psi
Country of Origin: United States

Hello everyone, new here. Need some help!

Friends car a/c stopped working, OBD1 code 66 for a/c low pressure detected.

1. Decide to convert to r-134a.
2. Replace accumulator, orfice tube and service fittings. Old orfice tube shows no sign of debris.
3. Run vac for 1 hour, no sign of leaks.
4. Remove vac pump, held vac for 30 min, no sign of leakage.
5. Attempt to charge system, Low rises to 70psi, compressor still does not engage.
6. Checked fuses, swapped relays with new/known good, nothing.
7. Jumper relay connection, a/c clutch engages.
8. Complete refrigerant charge. Cabin air nice and cold.
9. Low = 45psi, High= 190-225 psi, rises then falls cyclically. Cooling fans on and off as high rises and falls.
10. Replace a/c relay, jumper pressure switch connection on high side, cooling fans engage, no compressor.
11. Reconnect high side pressure switch.
12. Jumper low side pressure switch, nothing either way.

Sorry for being so long winded, but this is my first attempt at a/c, just trying to help a friend. Any help is appreciated!

Chick on Thu August 06, 2009 7:21 AM User is offlineView users profile

if the compressor starts by jumping the relay, and not the cycling switch, your stored code may be preventing 12v from getting to the cycling switch. Try a battery disconnect for a couple minutes to reset the computer, if that fails, check from the control head forward for the break in 12v..

Email: Chick


Freedoms just another word for nothing left to lose

GM Tech on Thu August 06, 2009 7:37 AM User is offline

reset your code 66 as Chick advised....

The number one A/C diagnostic tool there is- is to know how much refrigerant is in the system- this can only be done by recovering and weighing the refrigerant!!
Just a thought.... 65% of A/C failures in my 3200 car diagnostic database (GM vehicles) are due to loss of refrigerant due to a leak......

jiffyp20 on Thu August 06, 2009 11:04 PM User is offline

jiffyp20 on Thu August 06, 2009 11:05 PM User is offline

Thanks! I had a duh moment there!

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.