Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

Charging custom R134 converted ststem

bobcat37 on Sun August 02, 2009 5:42 PM User is offline

Year: 89
Make: Rockwood
Model: driftwood
Engine Size: 5.9
Refrigerant Type: R134a
Ambient Temp: 85
Pressure Low: 17
Pressure High: 165
Country of Origin: United States

Just completed reassembly of the system after flushing old mineral lube and debris : new Sanden comp. all hoses, filter drier, exp valve. added 8 oz PAG 100 balanced throughout, 4 cans R134. Still see foamy flow thru sight glass. Low side 17 psi, hi side 165psi, amb temp 85 deg. Air out of vents 50deg. Evap disch. line is frosting big time. some frost on EV . Engine RPM 900-1000.
I am concerned about the foamy fluid and puzzled that I have frost on both inlet and outlet of the evap. Is undercharge indicated? What pressures would be correct ( ambient temp 85-90 )? Thank you, bob

-------------------------
robert l fusco

TRB on Sun August 02, 2009 6:47 PM User is offlineView users profile

I would add a couple more ounces and re check pressures and temp. Don't use the site glass with R134a!

-------------------------

When considering your next auto A/C purchase, please consider the site that supports you: ACkits.com
Contact: ACKits.com

chris142 on Sun August 02, 2009 7:47 PM User is offline

Ya the site glass is useless with R134a. Paint over it.

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.