Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

82 Chevy doesn't seem to be as cold as last year

ferg on Tue June 23, 2009 1:06 PM User is offline

Year: 1982
Make: Chevy
Model: C10 (Truck)
Engine Size: 350
Refrigerant Type: r134a
Ambient Temp: 97
Pressure Low: 60
Pressure High: 300
Country of Origin: United States

I don't have an actual temp reading at the vents but the system doesn't seem to be as cold as it should . Last year I replaced nearly every component including compressor, converted to r134a and used this forum to get everything dialed in. I don't recall now what type of oil or how much or how much r134a i used but I did everything as recomended on this board. It worked fine but now it's not quite as cold as I feel it should be. Any thoughts?

The pressures listed were with the truck at idle and the AC on max cold. When the truck is off the high side reading is 150 if that helps any.

Edited: Tue June 23, 2009 at 1:07 PM by ferg

HVargas on Tue June 23, 2009 1:20 PM User is offlineView users profile

Sounds like you might have a slight overcharge or some moisture in the system.

-------------------------

When considering your next auto A/C purchase, please consider the site that supports you: ACkits.com
Contact: Arizona Mobile Air

Chick on Tue June 23, 2009 4:45 PM User is offlineView users profile

Leave the manifold hooked up and spray a mist of water on the condenser, if the pressures drop like a stone, you have air flow issues.. Might be time for a new fan clutch..

-------------------------
Chick
Email: Chick

---------------------------------------------

Freedoms just another word for nothing left to lose

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.