Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

A/C compressor constant ON/OFF

RickMar on Mon June 01, 2009 8:14 PM User is offline

Year: 1999
Make: Mercury
Model: Mountaineer
Engine Size: 5.0L

Hello,
Thank you for taking the time to read this post.
I have a 1999 Mercury Mountaineer 5.0L
My auto A/C has been non functional for a couple of years. The compressor fried up so I bypassed it with a shorter belt
5 days ago I had my A/C system repaired and running again.
When I picked it up it was blowing cold air but it did not seem to be to perform like it used to.
Before A/C would get very cold and actually would need to shut it down periodically.
Today I popped the hood and I noticed the clutch "front part" would engage for about 5 seconds the disengage for just about the same amount
of time. It would do this over and over .... ON/Off - ON/Off continuously.

A mechanic told me that was a sign of the freon in the system being low.
Could you tell me if you agree with the diagnosis?
Any information will be greatly appreciated.
Thank you.
Rick

Chick on Mon June 01, 2009 8:42 PM User is offlineView users profile

High and low side pressures would help, but "generally" it's a sign of low charge. But it could also be shutting down due to high pressure, like an overcharge, or poor air flow. Pressures are needed to confirm low charge.. Hope this helps..

BTW bring it back to the shop that repaired it to check pressures...??

-------------------------
Chick
Email: Chick

---------------------------------------------

Freedoms just another word for nothing left to lose

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.