Automotive Air Conditioning Information Forum (Archives)

Provided by

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

A/C not blowing very cold

nmumford on Mon July 28, 2008 2:25 PM User is offlineView users profile

Year: 1973
Make: Chevrolet
Model: Caprice
Engine Size: 400
Refrigerant Type: r134

Hello fellows i hope you guys can help me. This is the problem im having. I took my 73 caprice to the a/c shop to have the checked and they told me that the compressor was leaking and my POA valve was clogged and not operationing properly. So i purchased a new compressor and a new POA valve from the parts guy caribrated for 134. The problem i having now is my a/c is not getting as cold as it was last summer. I took it to a mechinic this moring and he told me that it had plenty on freon in it but my fan clutch on my motor is not coooling my condensor properly and he said that i needed to replace that and also put a after market electric fan on the condensor to cool it off better. Does this sound right. I would think the a/c should be real cold and when the engine got hot then it woulded get so cold if this was the problem. If theres anybody out there that can help i would greatly appreciate it.

Chick on Mon July 28, 2008 2:27 PM User is offlineView users profile

It's a good possibility, but your pressures would help us help you better..Get both low and high side pressures and post them..Hope this helps..

Proper air flow across the condenser is very important..Does it cool better going down the road for instance??

Email: Chick


Freedoms just another word for nothing left to lose

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.