Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

A/C running and not cycling off and no cool air

atktnc on Wed June 25, 2008 10:49 AM User is offline

Year: 99
Make: dodge
Model: grand caravan
Engine Size: 3.3
Refrigerant Type: 134a

Have a dodge caravan with a/c always on and not cycling off but no cool air . I do have rear a/c in vehicle and a hissing sound is heard while a/c is on. Before this i tried to add some refrigerant thinking it may be low. A/C was ok at that time but not very cold. Now it just blows no cool air . Is it possible that i overfilled the system or do i need to take it to shop to get them to fix it?

TRB on Wed June 25, 2008 12:52 PM User is offlineView users profile

Need some low and high side pressure readings!

-------------------------

When considering your next auto A/C purchase, please consider the site that supports you: ACkits.com
Contact: ACKits.com

webbch on Wed June 25, 2008 2:17 PM User is offlineView users profile

I've heard the "hissing" noise is from the TXV receiving refrigernat vapor as an input (when it should be receiving liquid refrigerant), and is commonly attributed to a low refrigerant level. Could air in the lines have the same effect? I wonder if you got air in the system when you tried to put in the refrigerant. But by all means, low/high side pressures at a given ambient temperature would be helpful.

Chad

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.