Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

A/C BLOWING HOT PLEASE HELP!!

hib on Mon June 16, 2008 1:57 PM User is offline

Year: 1999
Make: SUZUKI
Model: GRAND VITARA
Engine Size: 2.5
Refrigerant Type: R134-A
Ambient Temp: 90
Pressure Low: 100
Pressure High: ?
Country of Origin: United States

TextHello
I hope someone can help me. My Suzuki grand Vitara (1999) Ac stopped working. Before I saw white frothy stuff flowing thru the sight glass..NOW its clear . It's blowing warm. The compressor is turning and both fans come on. When I went to add a can of freon on the LOW SIDE, the gauge on my blue hose (attached to can) went up to 100 PSI on the low side! I know its only suppose to be around 30 psi or so.
Why is my air not working? Also, the FREON would NOt go into the low side from the can..the can was pierced and all, and I am on the correct fitting (low side). I did not evacuate or recharge when trying to add this can and think my compressor is coming on and turning in front, but maybe not pumping??
ANY HELP ASAP ..much appreciate! Site glass clear. car blowing warm still..THE A/c fuse is good but I see the Clutch PULLEY to compressor moves and comes on..but how do I tell if compressor is working? ALso, I can turn the clutch compressor VERY easy by hand..maybe its broke??HOT HERE IN FLORIDA..PLEASE help..
also, any ac relay on this car..what would cause this?

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.