Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

system pressures funky

mbill on Sun June 01, 2008 6:49 PM User is offline

Year: 1970
Make: cadillac
Model: deville
Engine Size: 472
Refrigerant Type: r12
Ambient Temp: 80
Pressure Low: 40
Pressure High: 200
Country of Origin: United States

got out my 70 cadillac checked air ran 15 minutes had foamy sight glass added 12oz r12 sight glass cleared poa and suction line cool and wet.vent temp 60 at idle poa pressure 50 ran engine up to speed vent temp 44 poa pressure 40 what is going on i thought the poa port should always read 29

Chick on Mon June 02, 2008 6:38 AM User is offlineView users profile

Are you sure you're using R12, and not an R12 replacement? could there be air in the system? Your POA could be on it's way out. Did you try recovering the refrigerant and recharging it back to factory amount? Has the system ever been serviced by you before?

-------------------------
Chick
Email: Chick

---------------------------------------------

Freedoms just another word for nothing left to lose

mbill on Mon June 02, 2008 3:00 PM User is offline

using real r12 bought back in the eighties had evaporator replaced and professional service 3 years ago. first problem and first time for me to work on it . did not evacuat and recharge dont have the equipment

mk378 on Mon June 02, 2008 3:22 PM User is offline

Is there a port on the compressor low side after the POA? Measure pressure there too with engine at speed. If it is way lower 40 then the POA is defective, closing too soon.

mbill on Mon June 02, 2008 6:28 PM User is offline

no just the one port on the poa and one on the high side

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.