Automotive Air Conditioning Information Forum (Archives)

Provided by www.ACkits.com

We've updated our forums!
Click here to visit the new forum

Archive Home

Search Auto AC Forum Archives

Does not cycle compressor

Barrnone on Fri May 16, 2008 9:43 PM User is offline

Year: 1995
Make: Chevrolet
Model: Tahoe
Engine Size: 5.7
Refrigerant Type: 134a
Ambient Temp: 101
Pressure Low: 52
Pressure High: 310
Country of Origin: United States

I need a little help to know if I should be concerned, I have only had this vehicle through the winter and I am not sure what it's normal operation is like.
The above pressures are at idle (about 600RPM). If I bring the engine up to about 2000RPM with the fan clutch engaged I get low side 25 high 230. When the fan clutch disengages the low is 34 high 320. Other wise the pressures doesn't seem to fluctuate and the compressor never seems to cycle off. The vent temps showed 50 at 2000RPM and 61 at idle.

Thanks for any help.

Layne

Chick on Fri May 16, 2008 10:41 PM User is offlineView users profile

Don't expect much cycling at 101 degrees, it will only cycle when it needs to, to keep the evap from freezing up. Pressures seem normal for that temp, although I don't usually see those tempts in NJ..I'm sure Tim will know if it's normal.. If you can wait til night time, run the AC on low fan, it may cycle..if it gets cold enough...

-------------------------
Chick
Email: Chick

---------------------------------------------

Freedoms just another word for nothing left to lose

Back to Automotive Air Conditioning Forum

We've updated our forums!
Click here to visit the new forum

Archive Home

Copyright © 2016 Arizona Mobile Air Inc.